TSL Automation Solutions Logo

Section 15.2.2 · Chapter 15: Using Macros

Opening and Closing Macros

■ Opening an existing native script

To open a global native script, select the native script you want to open in Project > Global Macros > Native Scripts Edit menu, or double click the native script in Global > Global Macros > Native Scripts node ( ) in the Project Manager tool window, or in the Macro settings of the object configuration dialog, select the native script that is located after "--------------Global NS-----------" item in the drop-down list.

To open a local native script, select the native script you want to open on Panel > Macro > Native Scripts Edit menu, or double click the native script in the panel application > Macros > Native Scripts node ( ) in the Project Manager tool window, or in the Macro settings of the object configuration dialog, select the native script that is located after "--------------Local NS-----------" item in the drop-down list.

■ Opening a *.txt or *.mcr file within the native script editor window:

You may do the drag-and-drop operation:
1) Open the native script editor window by clicking any of the existing native scripts.
2) Drag a selection of *.mcr file or *.txt file into the native script editor window and drop it.
Note: Any native scripts in the native script editor window will be replaced by native scripts from the source file.

■ Closing Native Script Editor Windows:

To close a single window, select the window and click the close button.
To close all windows, choose Windows... on the Window menu, select all the native script editor windows you want to close in the window dialog and then click Close Window(s) button.
Note: The Native Script Command Properties Window will be closed automatically when the native script editor window is closed. Even if the native script editor window is closed, all the changes will be saved, unless the software exits without saving any changes to the file.

■ Closing Native Script Command Properties Window:

To close the native script command properties window, click the close button on the Native Script Command Properties window or check/uncheck the Native Script Command Properties command on the View menu

Need PM Designer itself?

V4 for current PK, PT, ITV and PM panels, V2 for older models. Free, sent by email.

Source.Section 15.2.2 of the PM Designer Software User Manual, Edition 2.0, © Cermate Technologies Inc. (www.cermate.com, service@cermate.com). Reproduced online, with the manual's own figures, by TSL Automation Solutions, authorised Cermate distributor, for users of Cermate HMI panels. PM Designer and PanelMaster are trademarks of Cermate Technologies Inc.

Text and figures are the manufacturer's and may describe features your panel or software version does not have. For a plain-language introduction read the PM Designer guide; for help with a specific panel contact TSL Automation.